Yes we do. As of Jan 2018, we currently support Magento 2.2 and will suport all future versions when released.